
 

 

 

 

 

Advanced Excel 
 

 

 

Automate with Macros 

• Record and Edit Macros 

• Play Macros with Shortcuts and Buttons 

• Write Macros in the Visual Basic Editor 

▪ Message Boxes, Loops, and Triggers 

Advanced Formatting 

• Create Complex Forms 

• Advanced Data Validation 

• Active X Controls – Checkboxes, Form Fields, Calendars, Buttons 

Perform Advanced Functions – Logical, Lookup, Text, Date and Time, Text, Nested 

▪ Absolute Reference – Naming Cells and Ranges 

▪ Formula Auditing 

Creating Data Models 

Pivot Tables and Pivot Charts 

▪ Group Data 

▪ Calculated Fields 

▪ Advanced Analysis and Reporting 

Conditional Formatting 

Web Queries 

Custom Views
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Macros 

A macro is a recording of keystrokes and mouse clicks that can be played back.  
Any set of tasks performed exactly the same way every time is a good candidate for a macro 

Create a Macro: 
1. On the View tab, in the Macros group, click the Macros dropdown arrow and select Record Macro 
2. Name the macro  
3. Assign a shortcut key (optional) 
3. Choose where the macro should be stored (the workbook where the macro is stored must be open for the macro 
to run) 
 a. Personal Macro Workbook (always available when you are logged in)  

b. New Workbook 
c. This Workbook (travels with the workbook) 

4. Provide description (optional) 
5. Click OK 
6. Perform the commands you want to record 
7. Go back to the Macros group on the View tab, and choose Stop 
Recording from the drop-down menu 

 
Run a Macro: 
1.  Select the View tab 
2.  Click the Macros button above the drop-down arrow 
3.  Select the macro you want from the Macro name list 
4.  Click Run 
 

Edit a Macro: 
1.  Go to the View tab 
2.  Click the Macros drop-down 
3.  Select View Macros 
4.  Select the macro you want to edit (if the Macro is stored in the Personal Macro Workbook, you will need to 
unhide it from the Window group of the View tab) 
5.  Click Edit 
6.  Make text edits to the code 
7.  Close, and Return to Microsoft Excel 

Step Through the Code – The Step Into feature allows you to watch the macro perform a line of code at a time so 

you can “see” which line is causing you trouble. 

1. Open the VBA editor and click in the macro you wish to review. Make sure to also have your Excel window open 
and visible. 
2. Select Debug > Step Into or F8 to initiate. 

3. A yellow highlight will indicate which line Excel is executing. Continue hitting F8 until the program is complete. 
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Add Macros to the QAT: 

1. Click the Office button 
2. Click the Excel Options button 
3. In the Customize panel, select Macros from the Choose 
command from dropdown menu 
4. In the Customize Quick Access Toolbar, select For all documents 
5. In the left pane, select the macro to be added to the QAT 
6. Click the Add button 
7.   Click the Modify button beneath the right pane 
8. Type a name for the shortcut in the Display name field 
9.  Select an image for the shortcut in the Symbol pane 
10. Click OK 
11. Click OK in the Excel Options window. 
12. Review the QAT to see the macro's shortcut with the selected 
icon button 

Add Macro Buttons to a Worksheet: 

1. On the Developer Tab in the Controls group, click the Insert drop-down arrow, and choose Button 
2. Drag the button on the Developer Tab to the place you want it on the worksheet, and size it 
4. Select a macro to assign to the button (this option pops up when you release the mouse button) 
5.  Click OK  
6.  Rename the button 

Write or Edit in the VBA Editor  

1. Press ALT + F11 to open the VBA editor  
2. Select the project in the Project Window that you 
want (Most macros are stored in modules).  
3. Place your cursor in the code module between 
the Sub and End Sub declarations  
4. Type in the macro procedures 
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 Trigger a Macro from an Event  
 
You may want a macro to run based on some action you have taken. You might want a message box to 
appear when a user opens a worksheet with information about what is included. Or, you may want to run a 
macro that sorts your data into your preferred format each time the workbook is saved.  
 

1. Record or plan your Macro.  
2. Open VBA Editor.  
3. Double-click the module that will store the macro in the Project Window. Event Procedures are not stored in 
Code Modules like the macros seen so far. Instead, they will be stored in one of two places:  

a. Worksheet module – Macros will run when events happen in or to a specific worksheet.  
b. ThisWorkbook – Macros will run when events happen in or to the workbook.  

4. Change the (General) dropdown menu to Worksheet or Workbook. [A]  
5. Choose the action that will trigger the macro in the worksheet. [B] Excel will create open and close Sub 
statements. [C] Note that Excel creates a Private Sub procedure for this type of macro. This simply means that the 
macro will not be seen in Excel’s Macro dialog box – it can only be run when the event, or trigger, is detected (or 
from the VBA editor).  
6. Type or copy/paste your macro between the Sub statements as usual. [D]  
7. Save and test. 

 

Add a message box to an existing macro. Syntax:  MsgBo x ( [TE XT ] ,  [BUTTO NS ] ,  [TITLE])  

Message boxes are ‘pop up’ messages that grab the user’s attention and require a response before they continue.  
Sub Msg_exe()   
MsgBox "This is a message!", vbExclamation, "This is the Title"   
End Sub   
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Formulas and Functions 

 

Name Cells and Ranges 

1. Select the cell(s) to be included in the named range 

2. Click the Name Box 

3. Type a name for the range 

4. Press Enter 

The cell or range can still be referred to by the row and column reference, but it can also be referred to by its name 

Text Functions 

PROPER  Capitalizes the first letter in each text string 

UPPER  Changes text to all caps LOWER  Changes text to all lower case 

CONCATENATE Combines several text strings into one string 

TRIM Removes any leading or trailing spaces from a text string 

LEFT RIGHT MID  Return a specific number of characters from a location 
within a text string 
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Convert Text to Columns: 

1. Select the column to be split 
2. On the Data tab, in the Data Tools group, click the Text to 
Columns button 
3. Select the Delimited radio button 
4. Click the Next button 
5. Select the Delimiter(s) 
6. Click the Finish button 
7. Review your split columns 

 

Absolute Reference 

If you do not want the reference to a cell to change when you copy it to a new location, you can lock in the 

reference by making it absolute. The way to do this is to put a dollar sign in front of the reference you want to lock 

in. If you are referring to a single cell and do not want the reference to change no matter what direction it moves, 

lock it in by putting a dollar sign before BOTH the column and the row reference $C$4 

You can also lock in just the row C$4 or just the column $C4 

You can type the dollar signs or use F4 to toggle through the 4 types of reference:   $C$4    C$4    $C4    C4 

The IF Function =IF (Logical Test, Value if True, Value if False) 

The IF function is the function that allows many other functions to work correctly. How many times do you have 

everything set, then you realize there is a caveat or exception? 
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Formula Auditing 

The Formula Auditing Tools on the Formulas tab can help you gain clarity on what is going on with the formulas in 
your spreadsheet. 

Trace Precedents Shows the cells used in 

calculating the value of a cell. Note: Click the Trace 
Precedents button more than once to see all cells 
used. 

Trace Dependents Shows all the formulas in which 

a specific cell is used. Use Remove Arrows to stop 
showing Precedence or Dependence Arrows.  
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VLOOKUP Function 

The VLOOKUP function searches for a value in the leftmost column of a table and returns a value in the same row 
from a specified column in the table.  

=VLOOKUP (WHAT, WHERE, WHICH) 

What = What are you looking up based on?  

Where = Where are you looking it up? (Highlight [and name] the table) 

Which = Which column number (in your table) do you want to return data from? 

An optional fourth argument allows you to input, “FALSE: if an exact match is required. 
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Create a Custom Function  

If Excel does not have exactly the function you need, you can create your own using VBA. Review the Macros 
section for details about opening and editing VBA code.  
 

Create a Function Procedure  
1. Press ALT+F11 to open the VBA editor  
2. Select Insert > Module to insert a new Code Module  
3. Select Insert > Procedure  
4. Type a name for your function in the Name textbox  
5. Select Function radio button in the Type pane  
6. Click OK 
7. Function and End Function declarations will be added to your code window.  
 
Define the Function’s Arguments  - Type a short variable name for each argument the function will use to perform 
its calculations between the parenthesis that follow the function name. 
Enter a Formula – Enter the formula that the function will perform using the variables defined in the arguments.  

 

Custom Views – 

Print, Format, and Filter Settings  

1. Click the View Tab 
2. In the Workbook Views group,  
click Custom Views 
3. Click Add 
4. Give the view a name 
5. Access the view from the same location 
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Building the Dashboard 
 
Create a Dashboard using SUMIFS, COUNTIFS, and AVERAGEIFS 

You can create a dashboard using PowerPivot or with the OFFSET function and a scrollbar.  This module employs the 

SUMIFS, COUNTIFS, and AVERAGEIFS functions. 

Use SUMIFS, COUNTIFS, and AVERAGEIFS when you want to analyze the sum, count, or average based on multiple 

criteria. The syntax for COUNTIFS is the criteria range and criteria repeated until all criteria are added. 

=COUNTIFS(criteria_range1,criteria1,criteria_range2,criteria2,…) 

The SUMIFS and AVERAGEIFS syntax adds the sum or average range up front: 

=SUMIFS(sum_range, criteria_range1,criteria1,criteria_range2,criteria2,…) 

=AVERAGEIFS(average_range, criteria_range1,criteria1,criteria_range2,criteria2,…) 

We have gathered salary data on professional baseball players for the years 2010-2014.  

 

On a separate sheet, we drew the dashboard and created a corresponding combo chart for you. 

1. Use Data Validation to create a drop-down list of team names in cell C2 

2. Use the SUMIFS function to pull the salaries into column C 

3. Use COUNTIFS to bring the number of players into column D 

4. Write the formula to calculate the average in column E 
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Advanced Data Validation  

One of best ways to avoid errors in a database is to ensure that the data entered is accurate and consistent. Data 

Validation allows you to specify and enforce the format of data when it is being entered.  

Custom Criteria  

Use a formula to determine validation criteria  

1. 1. Select the cell or cells  

2. 2. Click Data Validation button in the Data Tools group 

on the Data tab  

3. 3. Choose Custom [B] from the Allow: dropdown options  

4. 4. Enter the formula that describes your validation rule 

 

This example counts the number of entries in a cell range and 

alerts the user if more than 3 suggestions have been entered. 

 

Form Controls 
Form controls can be very useful for adding form-like functionality to a 
workbook, without having to use VBA. Form controls make use of linked 
cells and the value in the linked cell is updated in some way, based on the 
actions taken with the form control at hand. Using formulas in 
combination with form controls, one can further extend the form control 
functionality and form-like appearance of the worksheet at hand.  
To change a control’s properties to link it to a background database sheet: 

1. Right-Click on the control and select Format Control. 

2. Modify control options as needed. 

3. To link the control to a background database sheet, input the 
destination cell address into the Cell Link. 
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Excel Data Models 

Prepare Your Data 
 
• Convert all data into tables with a Header Row. 
• Give each table a unique, useful name (this is not required, but very helpful). 
• Identify related data – Relationships are connections between two tables based on a single column in both that 
share a similar data. Plan which columns will become related in this way. It will also be very helpful to know which 
field you will want to summarize, later, in a PivotTable. 
 

Create Relationships 
 
1. Click Data > Relationships to open the Manage Relationships dialog 
2. Click New to open the Create Relationship dialog 
3. In the left pulldown menus, you will select two tables that have the same information 
4. In the right pulldown menu, you will specify which columns are the same in those tables.  then click OK 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
You can pull the data from your model into a Pivot 
Table 
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Pivot Tables 

You can take your spreadsheet apart column by column and put it back together in any configuration you 

want. Pivot Tables allow you to analyze and recombine data into reports and charts. 

1. Select one cell within the data 

2. Click Insert > Pivot Table > OK 

3. Check or drag items in the Field List to the 

Row, Filter, Column, or Values areas 

Right click Values column headers 

to change the operation 

Right click row and column headers to 

see Group options 

 

 

 

Explore the Pivot Table Tools Analyze and Design ribbons for options such as: 

Create Pivot Chart 

Hide Field List 

Insert Slicer 

Adjust Layout 

 

 

 

 

 

 

 

 

Make a Separate Sheet for All Values in a Field 

1. Drag the desired field to the Report Filter area 

2. On the Analyze Tab, click Options drop-down arrow in the PivotTable group 

3. Select Show Report Filter Pages 

4. Select the Field you want to use 



 

 

© 2019 Sherry Prindle         SherryPrindle.com 16 
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Conditional formatting  

1 Select the cell or range containing the values to which you want to apply conditional formatting 
2 In the Styles group, click Conditional Formatting 
3 Do one of the following: 

Choose a condition and rule from the menu 
Choose New Rule. Then specify a condition and format in the New Formatting Rule dialog box 

 

Power Query and Power Pivot 
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Setting Up a Web Query 
 
1. On the File tab, in the Get External Data group, select From Web 
2. In the Address field [B], type the Web address for the page that contains the information to be pulled into Excel 
3. Click the arrow next to the table(s) to be added to a spreadsheet 
4. Click the Import button 
5. Select the location for the data and click OK 


