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1 — Build a Workbook from Scratch

Worksheet Elements
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The strip of buttons and icons above the work area.

A collection of functionally- related controls and menus.

An individual spreadsheet with rows & columns or a chart.

A file containing multiple worksheets.

Marks the currently active cell or range.

Provides access to options such as open, save, print, etc.

Stores shortcuts to frequently used features,

T 6 m m M @

Hosts spedific shortcuts and information about a workbook,

Controls the magnification of the screen.

Launches the associated dialog oo

Displays the contents of the currently active cell.

= | &R| =

Displays the name of the currently active cell.
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Design a Spreadsheet

Mind map the content, then sketch the layout. Start by dumping out everything you would want to
include in the spreadsheet, the sub-group

Agenda

Blurb

Refreshments

Room Setup

BEOs

Time

Research

Each main topic is a separate workbook or sheet. Branches are column headings.

Seminar

by which to divide sheets

Topic

Date

Location

Cost

Advertising

Materials

Travel

Agenda

Research

Materials

Refreshments

Room Setup

Travel

BEOs

Name
Organization
Address
Email

Phone

Logistics

Attendees

Sketch out a spreadsheet to track 5 products across 12 months:

Seminar

Advertising

General Info

Blurb
Direct Mail
Media Web Ads
Print Ads

Demographic

Frequency

Topic
Date
Time
Cost

Location

One of the branches is the variable

Design your spreadsheets to grow downward. Also remember you can only sort and filter vertically, so put the items
you would likely want to manipulate into the rows
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Find, Create, and Use Templates

Locate a Template:
Rather than starting with a blank workbook, get started with something
that gives you a start on content, formatting, and layout

1
2
3
3
4
5

. Click the File Tab

. Select New

. Search for Online Templates

. Single-click to preview or double-click to open the desired template
. Pin Favorite Templates [A]

. Edit and save as a Workbook or Template

Book1 - Excel Create a Tem plate:

New 1. Create the workbook you want
to save as a template
2. Click File > Save As...

Search for online templates o
Suggested searches:  Business Personal Industry Small Business Calculator  Finance - Accounting  Lists 3. Name the file

3. In the Save as Type drop-down,
choose Excel Template

FEATURED ~ PERSOMAL

Open a Saved Template:

Save As
1. Click the File Tab
™ C

2. Select New (L) Recent
3. Click Personal

Users > shery > Dropbox > Computer Instruction

ExcedPracticeFilesPryor

4. Double-click the desired template @ Onelive Newoce venures
. E;} Sites - NewVoice Ventures
What makes saving a workbook as a template PR e T T
different than just saving it? & Onebrive
jl‘;l This PC

What can you use templates for?

search for online templates pel

Suggested searches: Business  Personal Industry  Financial Manegement Lists Logs Calculator

FEATURED

A B C EMPLOYER ATTENDANCE RECORD LM AMCHTTEA T 10N SCHTTRAL

-

o

[N

4 ‘
3 KEY STATISTICS = i
2 ER EIl 50 e o e = IR 5. =0
Vi
Blsckc workdiook Employee attendance tracker ) Loan amortization schedule A
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Automate Date Entry with AutofFill

Type data into a cell:

1. Select an empty cell
2. Type the information
3. Leave the cell (Press ENTER or TAB on the keyboard, or click into another cell)

Edit data in a cell:

1. Select the data in the cell containing the information to be edited. This can be done three ways:
a. Double-click the cell
b. Click the cell, and edit in the Formula Bar
c. Press the F2 key on the keyboard

2. Make any needed changes

4. Press ENTER or TAB on the keyboard

D

Replace information in a cell: Sunday

1. Select the cell containing the information to be replaced |
2. Type the new information +
3. Press ENTER or TAB on the keyboard

Copy Data or Fill a Series with AutoFill:

You can use AutoFill to complete a series of numbers, months, days, dates, or other sequential data. The fill handle
is a small square in the lower-right corner of a selected cell or range of cells. When you point to the fill handle, the
pointer changes to a plus sign (+). Click and drag the pointer in any direction to fill a range with data.

To use AutoFill:

1. Select the cell containing the value that will start the series
2. Point to the fill handle until the pointer changes to a + symbol
3. Click and drag the fill handle over the adjacent cells that you want to fill

To teach Excel a pattern, select multiple cells with a desired range, and AutoFill will continue with the same
increments. For example, fill a range by 10s or fill a range with dates a week apart

Click the Options Icon that appears when you release the Fill Handle to take advantage of variations

Fri ¢ 10/2/2017
Sat 12 10/3/2017

B -
24
| | Fill Series

36
43

Fill Eormatting Only

. ) ) Fill Without Formatting
Auto Fill Options FilDays
Fill Weekdays
Fill Months
Fill Years

ocooococoo@o
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Insert, Delete, Move, and Manipulate Cells, Rows, and Columns

Insert Rows:

1. Right-click the number to the left of the row you want to insert rows above
2. From the right-click menu, click Insert
To insert multiple rows, select the number of rows you want to insert before right-clicking

Insert Columns: A
1. Right-click the letter above the column you want to insert columns in front of E" o
By Copy
2. From the right-click menu, click Insert i, | Paste Options
To insert multiple columns, select the number of columns you want to insert before right-clicking T
Paste Special...
Delete rows or columns: S
[E Format Cells...
1. Select the rows or columns you want to delete Bow Height..
2. From the right-click menu, click Delete s
Select cells, rows, and columns: o
Calibri |11 - A" & §-% + |
B I =&-A-H-gilw

Select rows or columns by clicking row and column headers. Click and drag across several column
or row headers to select multiple rows and columns

Select an entire worksheet by clicking the upper-leftmost button

Use the SHIFT Key to select adjacent items:

1. Click the first cell (or row or column)

2. Press and hold the SHIFT key on the keyboard while selecting a second cell (or row or column)
All cells between the two places you clicked will be selected

Use the CTRL Key to select non-adjacent items:

1. Click the first cell (or row or column)

2. Press and hold the CTRL key on the keyboard while selecting additional cells (or rows or columns)
All clicked items will be selected

Selection Shortcuts

CTRL+A: Selects All

CTRL+ARROW: Jumps from the active cell to the last non-blank cell in the direction of the arrow
SHIFT+ARROW: Highlights one cell at a time in the direction of the arrow

CTRL+SHIFT+ARROW: Selects all cells from the active cell to the last non-blank cell the direction of the arrow

Move the contents of cells, rows, or columns by clicking and dragging the highlight that surrounds the selection
Press and hold the CTRL key and drag to copy
Press and hold the SHIFT key and drag rows and columns to move them k2 - £

= I I R B VS e o R
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Insert, Copy, and Move Worksheets

Insert a Worksheet:

1. Click the tab of the worksheet you want to insert a worksheet after
2. Click the plus sign (+) to the right of the sheet tabs

Move or copy a worksheet:

1. Right-click the tab for the worksheet to be moved or copied

2. Select Move or Copy

3. Select the destination workbook from the To Book dropdown menu (the current workbook is selected by default)
4. Select the worksheet position in the destination workbook in the Before Sheet panel

S. Leave the Create a Copy checkbox unchecked to move the sheet or Click the Create a Copy checkbox to copy the
sheet

6. Click OK

You can also drag a sheet to move it. To copy a sheet quickly, press and hold the CTRL key on the keyboard while
clicking and dragging the sheet tab to new location

S — — - —Tmes wnman gy

Rename a worksheet:

Insert
1. Double-click the tab for the sheet to be renamed lifornia 6.887.00
D‘x Delete !
2. Type the new sheet name N
3. Press Enter lorida Rename 6,912.00
- Mo Copy...
eorgia woeereR- 5 .330.00
&Z View Code
idiana o ;s 3,778.00
Tab Color 4
Hide

Select All Sheets L

ts | Sales ‘N
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2 — Customize, Maneuver, and Modify

Format Cells, Rows, and Columns g ( ) - E

Resize Rows and Columns First Last Hire

1 | Name Name Date

2 |alan _|a|da 5/9/1995
3 |andie macdowell 6/8/1999
4 langelina jolie ERERERER

Sometimes number formatting will make the data too wide to be displayed at
the current column width. When this happens, Excel displays a series of number
signs (#) instead of a truncated number. (This is done because the visible part of
a truncated number might be mistaken for the complete number.) If number
signs are displayed, either increase the column width or change the formatting of the number

Excel automatically adjusts row height to accommodate the size of data in a row, while column widths need to be
adjusted manually. There are several ways you can change column widths:

*You cannot change the height or width of an individual cell without it changing the entire row or column
Drag the Right Column Border

When you point to the border between two column headings, the pointer changes to a two-headed arrow You can
then drag the border to the left or right to decrease or increase the column width

Double-click the Right Column Border
This automatically sizes the column to fit the widest data it contains
Set a Specific Numeric Column Size

To do this, right-click a column label (or select multiple columns and then right-click) and choose Column Width.
Then enter a width value and click OK The same options work for customizing row height

Setting Consistent Width of Multiple Columns

To set several contiguous columns to the same width, select the columns and then use one of the methods above to
change the width. This method also works for setting row height (do this instead of alternating blank rows)

FILE HOME MSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW DEVELOPER Sharyl
= X Cut _— i . 1 _ =] 0o o, e Autas .

& : Calibri M| KA = - ¥ Wrap Ted General - ‘FIL By | == .'IP\ n E viesum '%’1' H
Pasts = Conditons! Formatas Cell Defete Format | 5 Sort B Find &
Paste BT WU- - &- A-=== &+ EmMegeacCenter - § - % » 4 £ Conditional Formatas Cel msert Dedete Fonmat Sort & Fin

- Farmat Painter - 7" Formatting~ Toblex Styles~ | = . - £ Clear~ Filter = Select =

Clipboard ] Font @ Alignment ] Humber il Styles Cells #  Clear &

Format Cells

The Styles and Cells groups on the Home tab allow you to adjust multiple aspects of cell formatting. For more
options, click the Dialog Box Launcher in the lower right corner of a group

Number tab in the Format Cells dialog box offers a variety of number formats, including dates, times, fractions, and
scientific notation

Cell Alignment

Cells in Excel can be aligned both vertically and horizontally in the
Alignment Group on the Home tab. You can also change cell Orientation and indent

ignment

- % Format Cell Al
Firs. wuaswer wvacs

&

$9,700.00 $6,887.00 $7,954.00 $24,!
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Merge Cells Ty o e L TS

The Merge & Center button centers data over a range of

A ] ©

cells (instead of within a single column) Employee Salary Data

ini First
1. Select the cell containing the data you want to mergeand ~ fist S
center (If you have not yet typed the data, move tostep2) I, &L 511095 Cornorate Mane.. 5

2. Select the rest of the cells over which you want to center the data

F [P [vomas nowa

jormal 5 Homal .

Perf Mgmt

ual Salary Rating Level

$65,000.00

[ 348.000.00

3. On the Home tab in the Alignment group, click Merge & Center (You can enter data into the merged cells)

To unmerge, select the merged cell and click Merge & Center again
Wrap Text

Click the cell or range of cells where you want the text wrapping to take place.
On the Home tab, click Wrap Text. Adjust the row height as needed

Format Painter

Once a desired look has been achieved, it is easy to apply that same formatting to additional

cells using a tool called the Format Painter
Copy or paste formatting from one cell to another .
B3 Copy -
“fomatpainter B 1 U =
1. Select the cell with the formatting to be copied s
2. Click the Format Painter button in the Clipboard group on the Home tab = £ | Te
A B

3. Select the cells to which the formatting should be applied

First Quarter Sales

= - |22 Wrap Text General

Posit
Vice
Preside
Office @ Tell me more
Manage. o uuuus
Marketing
Manager $85,000.00
Director of
Advertising $46,000.00

- A A == &~ | LWapText

[EIMerge & Center = | $ - % *

5 1
3 2

h-A- == = &= [FMege&Center - $ - %

Alignment

tal Sales

€ D

When you release the mouse, the Format Painter automatically turns off

Copy or paste formatting several times: Florida
Georgia $4,712.00

1. Select the cells with the formatting to be copied Indkana | $9,657.00

2. Double-click the Format Painter button in the Clipboard group of the Home tab
3. Select the cells to which the formatting should be applied
4. Repeat as many times as necessary

January February March

$6;887.00 $7,954.00

$5,77400 $16,912.00 $6,349.00

$5,330.00 $1,990.00
$3,778.00 $5,555.00

S. Turn off the Format Painter by pressing the ESC on the keyboard or Paste clicking the Format Painter button again

CRERCE O
Customize the Quick Access Toolbar OME | INSERT

o X Cut

1. Click the Customize Quick Access Toolbar dropdown arrow P | ¥
2. Take one of three actions: et o
a. Select an unchecked item to add
b. Select a checked item to remove
c. Select the More Commands option to view additional options

A2

Customize the Ribbon i
1. Click the File tab 2 SFiow Belon the btk

2. Choose Options
3. In the Options dialog box, select Customize Ribbon
4. Add or remove items (like the Developer tab)

Customize the Status Bar

1. Right-click the Status Bar
2. Select an unchecked item to add or a checked item to remove

© 2019 Sherry Prindle Dawn Jones Productions  sherryprindle.com  dawn@dawnjones.net

Calibri

& S 8

PAGE LAY( Customize Quick Access Toolbar

I U~

Fon

S

Total Sales |
$24,541.00
$29,035.00
$12,032.00
$19,290.00

juli}
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Work with Multiple or Large Worksheets and Workbooks i TR T () - e

oeLayout  Formulas  Data  Review w  Developer Q) Tell mg

Group Sheets N Py b o o
1. Click the first sheet to be grouped
are . . C D E
2. Select additional sheets to include in the group
¢ Hold the SHIFT key on the keyboard while clicking a non-adjacent sheet to select Eistanartegsales
A . :bruary March .BE
both of the clicked sheets and all sheets between them e

6,887.00 $7,954.00 $:

¢ Hold the CTRL key on the keyboard while clicking to add individual sheets to the 691200 5634000  $3
5,330.00 $1,990.00 $1

SeIECtion Tab Colo » 3,778.00 $5,565.00 $1
3. Verify the grouped sheets are the ones intended e

e Grouped sheets are highlighted

e The term [Group] appears in the Title Bar
4. Make changes to any grouped sheet to apply those modifications to all grouped sheets
5. Ungroup sheets to stop sharing changes

e Click any ungrouped sheet

e Right-click any grouped sheet and select Ungroup Sheets

es3Q__ Sales 4Q | Sales Total | sum |G [

Window Workbooks and Worksheets
Hide Rows, Columns, and Sheets
To hide rows or columns:

1. Select a column heading or row heading, or drag across multiple column headings or row headings to make
your selection
2. Right-click the selection and choose Hide

You can also select an individual cell or range and, on the Home tab, click Format (in the Cells group), choose
Hide & Unhide, and then choose an option

When you want to use or view hidden rows or columns again, you can unhide them:

1. Select the rows or columns on both sides of the hidden row(s) or column(s)
2. On the Home tab, in the Cells group, click Format and choose Hide & Unhide; then choose Unhide Rows or
Unhide Columns

Hide and Unhide Worksheets

You can also hide and unhide entire worksheets. Simply right-click a worksheet tab and choose Hide. To unhide
a worksheet, right-click the active worksheet tab and choose Unhide. Select the name of the hidden tab you

Split a Worksheet: g — —
Click the View tab

Mew  Armange  Split Swmtch Macros
Click Split in the Window group Window Al Windows -

Drag the split bar(s) to where you want to split the worksheet

To remove a split, double-click the split bar. You can remove both horizontal and vertical splits by clicking the
Split button again

© 2019 Sherry Prindle Dawn Jones Productions  sherryprindle.com  dawn@dawnjones.net 9



View Multiple Workbooks in the Same Window:

1. Open the workbooks you want to view
In the View tab, in the Window group, choose View Side-by-Side or Arrange

3. View Side by Side allows you to choose from open workbooks and use synchronous scrolling. Click it again to
turn it off

4. Arrange automatically arranges all open workbooks and lets you choose the layout. Maximize the
workbooks to turn it off

View Multiple Sheets in the Same Window:

1. Open the workbook that contains the sheets you want to view
In the View tab, in the Window group, click New Window to open another view of the same workbook. You
can click it multiple times to get multiple views

3. Use View Side by Side or Arrange All to view the worksheets as explained above

4. You can edit in any window and, as long as you save changes, it will update the worksheets in the workbook

View Side by Side allows you to choose from open workbooks and use synchronous scrolling. Click it again to
turn it off

Arrange automatically arranges all open workbooks and lets you choose the layout. Maximize the workbooks to

turn it off
— .
== Q [‘3) ] | TENew Window MmO F I:l = Q [‘i, iel
= Q E Arrange All I E‘D D gelae = m Q
Show Zoom 100% Zoom to N Switch Macros Normal Page Break 1| Custom Views Show Zoom 100% Zoom to
- Selection 57 Freeze Panes - Windows ~ - Preview - Selection
Zoom ‘Window Macros -~ ‘Workbook Views Zoom
S Al 2 S
D E F G H . A B Z D
1 I
First Quarter Sales 2 [ Second Quarter Sal
v February March Total Sales 3 April May J1
00 $6,887.00 $7,954.00 $24,541.00 4 California $2,654.99 $4,568.00 $
00 $16,912.00 $6,349.00 $29,035.00 Arrange Windows ? < Florida $1,664.21 $9,986.75 $
00 $5,330.00 $1,990.00 $12,032.00 Georgia $8,756.42 $3,989.87 $
00 $3,778.00 $5,555.00 $19,290.00 rEmR Indiana $7,656.42 $8,765.32
lles 1Q PEEICEEL) | e q @ Tiled: @ Contacts |_ Sales 2Q
= m - ¥ () Horizontal
O vertical
ExcelPractice xce Sheryl Prindle O cascade Do & @& - ExcelPracticeFile
Page Layout Formulas Data Review [PIARSEINOR M) [ ] windows of active warkboak Insert Draw  Page Layout  Formulas D
— -
°5 q [5, CENewwndow [ [0 OO [E== cancel o= Q [5,
5 q B Arange Al — | T [ Page Layout = e Q
Show Zoom 100% Zoom to o Switch  Macros Normal Page Break [ custom Views  SMOW  Zoom 100% Zoom to
- Selection 57 Freeze Panes - Windows -~ Preview - Selection
Zoom ‘window Macros ~ ‘Workbook Views Zoom
I - S 3746
D E F G H 1 - A B C

Third Quarter Sales 1
August September [ T RCE EEY 2 Fou

0 $4,690.00 $20,000.00 $27,380.00
0 $16,912.00 $12,886.00 $35,572.00 3 October N

n =220 nn e10 noa nn ean nan nn
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Macros

A macro is a recording of keystrokes and mouse clicks that can be played back. Any set of tasks performed

exactly the same way every time is a good candidate for a macro

Create a Macro:
1. On the View tab, in the Macros group, click the Macros dropdown
arrow and select Record Macro
2. Name the macro
3. Assign a shortcut key (optional)
3. Choose where the macro should be stored (the workbook where the
macro is stored must be open for the macro to run)
a. Personal Macro Workbook (always available when you are
logged in)
b. New Workbook
c. This Workbook (travels with the workbook)
4. Provide description (optional)
5. Click OK
6. Perform the commands you want to record

Excel

Developer Q2 Tell me wh

{ = ] = | 2 split
to  New Amange Freeze
ion Window Al Panes-

[[1view Side by Side o |

T Hide = L
Switch | Macros

Windows -

Window Magros

Record Macro 7 x

Macro name:
E

Macrol

shortout key:
tal Sales curls
ore

$11,685.17
$21,439.49
$21,422.83
$23,187.17

7. Go back to the Macros group on the View tab, and choose Stop Recording from the drop-down menu

Run a Macro:

1. Select the View tab

2. Click the Macros button above the drop-down arrow
3. Select the macro you want from the Macro name list
4. Click Run

Edit a Macro:

1. Go to the View tab

2. Click the Macros drop-down
3. Select View Macros

4. Select the macro you want to edit. (if the Macro is stored in the Personal Macro Workbook, you will need to

unhide it from the Window group of the View tab)
5. Click Edit

6. Make text edits to the code

7. Close, and Return to Microsoft Excel

What kinds of things would recording a Macro work well for?

sherryprindle.com
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3 - Create and Manipulate Reports

Sort - You can sort data alphabetically, chronologically, or numerically

Quick Sort
> AutoSum ~ A
1. Click a cell in the column by which the data should be sorted = Eil ZY ,Q
2. Click the Sort & Filter drop-down in the Editing group on the Home tab A Sort & Find &
3. Select a sort method Clear~ Filter = Select ~
Editi #| SortAtoZ
Or Z| SortZtoA
1. Right-click any cell in the column by which the data should be sorted ¥t] Custom Sort...
2. Select Sort 2 Y Filter
3. Select a sort method
Multi-Level Sort
1. Click anywhere in the data to be sorted
2. Choose Custom Sort in the Sort & Filter drop-down in the Editing group on the Home tab
3. Choose the column and aspect you want to sort based on as well as the order
4. Repeat step 3 for multiple levels
"'i*l Add Level }{ Delete Level E|’E“| Copy Level Options... My data has headers
Column Sort On Crrder
Sort by Values | [AtozZ -
First Mame
Last Name
Hire Date
55#
Department
Pasition
Annual Salary
Perf Rating
Mgmt Level

Cancel

4 |INCO Manager Sharon Tanner 555 Ocean Anchorage AK 45637 Retailer
5 |Labs Plus Sort ? ailer
6 |ViaGraphix ailer
7 |Compu-Techs +£l Add Level || < Delete Level || ) Copy Level ||| & Options... My data has headers  ailer
8 g:nwel‘ Column Sort On Order :Ier
9 utor
Sortby | Distributor or Retaile[w | [Values v| |AtozZ v
10 |Ford Then by butor
State Values AtoZ =
11|Sony s ¥ ¥l aler
Then b i =
12 |Warner Bro. v |city v| |Values v| |AtoZ ~I| ailer
13 |Mckinsey Thenby | Company w | |values w| [AtoZ v | ailer
14 |Seeley Then by |Revenue Generated |w | |Values w  largest to Smallest ™ ailer
15 | Toyota ailer
16 |CB Commercial ailer
17 |Chrysler Cancel butor
12 [N _lanac ailar

© 2019 Sherry Prindle Dawn Jones Productions  sherryprindle.com  dawn@dawnjones.net

$89,891
$33,222
$14,155
$56,666
$76,511
$23,000
$13,223
$64,526
$53,355
$55,442
$72,399
$43,232
$44,000
$23,444
SRR ARR
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Filter — Query and Clean up
AutoFilter:

1. Click any cell in the data

2. Click the Filter button in the Sort & Filter group on the Data tab of the Ribbon
3. Click the dropdown button at the top of the column to be filtered

4. Uncheck all but the desired range(s) from the Filters window

5. Click OK

You can also use Text Filters and Number Filters to select data to sort
Subtotals

Excel can automatically calculate subtotals at every change of data in a key column
1. Sort a list by a key column

2. 0n the Data tab, in the Outline group, click Subtotal

3. Use dropdown arrows to configure desired settings

4. Click OK

Format as Table

Data Validation ? X

Settings  Input Message  Error Alert

Validation criteria

Allow:

Any value
A

Ignare blank

Apply these changes to all other cells with the same settings

Clear All Caneel

Use function:
Sum ~

Add subtotal to:

[Jss= A
D Department

[ rosition

Annual Salary

Perf Rating

(W Migmt Level v

2| Replace current subtotals
:| Page break between groups
2| Summary below data

Remaove All Cancel

On the Home ribbon, Format as Table automates alternate row shading, freeze panes, the filter, and adding a total

row. Tab from the last data cell to add rows

H - [} @ E A - ExcelPM - Excel TABLE TOOLS
FILE HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW DEVELOPER DESIGN

¥| Header Row First Column

Table Name: Summarizewith PivotTable D
=)

Tahblel E‘E Remove Duplicates
Insert | Export Refresh

Slicer

V| Total Row Last Colurnn

‘Ij' Resize Table Convert to Range ¥| Banded Rows Banded Columns

| Filter Button

Properties Tools External Table Data Table Style Options Table Styles
122 - fr | stan7
First Name ~ | Last Name ~ || Department - | Job Title - | Salary ~ | Perf Rating ~ | Mgt Level - |Training Hours |~ LMS
19 | James Parker Sales Product Management $  48,000.00 2 4 56 TCR
20 |Harold Robbins Section Manager Circulation Manager $ 38,500.00 5 3 24 TCR
21 |Susan Sarandon Section Manager Dir. of Shipping $ 55000.00 1 3 48 TCR.
22| Laurent Yves Saint Section Manager Dir. of Training $  45000.00 2 3 36[Start7__|
23 Total $1,140,500.00 1.400680107 1.228571429 547 21)

1. Click any cell in the data to be converted to a list

2. On the Home tab, in the Styles group, click Format As Table
3. Select a formatting option

4. Click OK to confirm the data range

5. Review your completed table

Flash Fill

You can format, combine, parse, and clean up data by just typing the desired outcome into a blank cell in the same

row as the data, hitting enter, and starting to type it again the next cell down

Zip Revenue
City State | Code ID# Generated
Miami FL 178688 123-23-1232 $72,399 123 @ Miami, FL 78688
Los Angeles CA 45637 | 436-36-5435 $64,526 436 @ Los Angeles, CA 45637
Dallas TX 156466 534-83-4872 $13,245 534 @ Dallas, TX 56466|
Seattle WA 90000 | 004-36-3264 $32,211
Miami FL 178688 687-43-4535 $43,232
Mobile AL 88890 | 047-46-3245 $14,155
Denver CO 134255 747-22-5343 $53,355
Miami FL 78688 | 124-34-5435 $72,399
Dallas TX 156466 643-24-3364 $81,122
Tucson AZ 98099 | 063-47-4553 $32,331
Newport Beach CA 67850 123-23-1232  $23,000 _wnjones.net
Los Angeles CA 45637 | 123-23-1232 $64,526
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Data Validation

To ensure the proper type of data is being entered, Excel can validate it upon entry

1. Highlight the cells where data validation will be applied

2. On the Data tab, in the Data Tools group, click Data Validation

3. Select the validation criteria

4. Provide any additional parameters

5. Create optional Input and/or Error Messages
6. Click OK

Securing Data
File Protection:

. Click File

. Click Save As

. Click Excel Workbook

. Click the Tools dropdown arrow

. Select General Options

. Enter a Password to open and/ or edit the workbook
. Click OK

N O L WN R

Cell Protection:

. Right-click the cells to remain editable
. Select Format Cells

. Click the Protection tab

. Uncheck the Locked box

. Click OK

. Click the Review tab

. Click Protect Sheet

. Create and confirm a Password

. Click OK

O 00 N O Ul A WN -

Lock all cells by performing only steps 6 through 9

© 2019 Sherry Prindle Dawn Jones Productions  sherryprindle.com

Data Validation ? X

Settings  Input Message  Error Alert

Validation criteria

Allow:

Any value
A

Ignare blank

Apply these changes to all other cells with the same settings

Clear All

opbox > Dawn and Sherry Projects > Excel

oo ety

L 3 Protect and Share Workbook

3 Allow Users to Edit Ranges

Protect Protect  Share
Sheet Workbook Workboak [ Track Changes ~

Changes

Protect Sheet 7%
[ Protect worksheet and contents of locked cells
Password to unprotect sheet:
|
Aligw all users of this worksheet to:
[Blseleaiockeacens N

Select unlocked cells

dawn@dawnjones.net
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Print — Total Control of How It Shows Up on Paper
Set a Print Area

1 Select the range to be printed
2 On the Page Layout tab, in the Page Setup group, click Print Area and choose Set Print Area
3 Click the File tab and click Print to preview and verify that only the print area will be printed

Print Scaling and Orientation

On the File tab, click Print to display your print options, which include page orientation, collation, paper size,
margins, and scaling

You can also change these settings from the Page Layout tab

On the Page Layout tab, in the Scale to Fit group, you can fit spreadsheets to the desired with and number of pages.
You can also adjust the percent of scaling

Margins
On the Page Layout tab, in the Page Setup group, adjust margins to Normal, Wide, Narrow, or Custom
Print Titles

If your data headings appear on only the first page, the data on the other pages will be hard to interpret. You can
set Print Titles to specify which text should print as headings on all pages:

1. Click the Page Layout tab

2. In the Page Setup group, click Print Titles. The Page Setup dialog box opens with the Sheet tab active

3. Under Print titles, enter the range containing the titles that you want to print on each page. You can select the
rows to repeat at the top of all pages, columns to repeat on the left side of all pages, or both

4, Click OK

Add Headers and Footers

1. Click the Insert tab

2. In the Text group, click Header & Footer. Page Layout view is activated, with the Header & Footer Tools Design
tab displayed. An empty header box appears in the top center of the first page

3. Add text and any other elements you want to include, or you can add items from the Header & Footer Elements
group or use preset headers and footers

When you finish with the header or don’t want one, click Go to Footer in the Navigation group, and follow the
above steps to insert a footer

Edit or delete headers and footers manually by clicking into the header and footer area

O = [a E - ExcelPracticeFiles:2 - Excel

Home Insert Draw Page Layout Formulas Data Review View Developer Q Tell me what you want to do

@ Dm IDM [E E'I\E TS Width: Automatic - | Gridlines |Headings = EL\ 1
= r s = . . . €
¢ [|Height: Automatic - View View y
Margins Orientation Size  Print Background Print w” g S S Bring Send  Selection Align

- - -~ Area~ Titles | [s/Scale:  100% © [Jprnt |CIPrint | Forward - Backward - Pane -
Themes Page Setup I Scale to Fit o4 Sheet Options [ Arrange

© 2019 Sherry Prindle Dawn Jones Productions  sherryprindle.com  dawn@dawnjones.net 15



4 —Formulas and Functions

Formula Syntax and Order of Operations =9+3*4
. All Excel formulas start with a
X o« fr ] =viookup(as =" “=% and can either be selected
- £ - VLOOKUP (lookup_value, table_array, col_index_num, [range_lockup] from the formula I|bra|’y or typed

T directly into the formula bar

As you begin to type a formula, a pop-up will appear to guide you through each step, shown in bold

‘A1:C4  A1,C4

A1

Single-cell references describe a Array references describe a Non-contiguous references
cell's location within a worksheet, in contiguous group of cells based describe selections of individual
terms of the intersection between a on the location of the top-left (A1) cells that do not share a common
column (A through XFD), and a row and the bottom-right (C4) cells, border, separated by a ,”

(1 through 1,048,576) . | separated by a “:” T —— . . B

4

s | —— 4

Calculations are carried out according to the mathematical "Order of Operations"

Parentheses

Exponents

Multiplication and Division
Addition and Subtraction

el
>0 mMT

If there is more than one instance of a type of calculation, Excel calculates from left to right

Reference Cells

Reference cells in formulas by typing the cell reference or clicking on the cell to enter it into the formula
Compose a formula:

1. Type and equal sign (=)

2. Click the first cell

3. Type an operator (+ to add, - to subtract, * to multiply, / to divide)

4. Click the next cell

5. Continue until the formula is complete, then press Enter to calculate and move the cursor down or Tab to
calculate and move the cursor to the right

A B C
1 Item 1 Item 2 Total
2 12 6 subtract
3 9 14 multiply
4 18 2 divide

© 2019 Sherry Prindle Dawn Jones Productions  sherryprindle.com  dawn@dawnjones.net 16




AutoFill Formulas - Relative Reference

1. Select the cell containing the formula

2. Point to the fill handle until the pointer changes to a + symbol

3. Click and drag the fill handle over the adjacent cells that you want to fill the formula into

Excel adjusts the cell references in the formula relative to where you move it. If you fill down, the row reference
adjusts, if you move across, the column reference changes. If you copy and paste a formula, both the row and
column reference change relative to the distance the formula has been moved

AutoFill Formulas - Absolute Reference

If you do not want the reference to a cell to change when you copy it to a new location, you can lock in the
reference by making it absolute. The way to do this is to put a dollar sign in front of the reference you want to lock
in. If you are referring to a single cell and do not want the reference to change no matter what direction it moves,
lock it in by putting a dollar sign before BOTH the column and the row reference $C$4

You can also lock in just the row C$4 or just the column $C4

You can type the dollar signs or use F4 to toggle through the 4 types of reference: $C$4 CS$4 S$C4 C4

A B C
Tax Rate 8.25%

1

2

3 Prices | Shipping Total
4 $12.00 $2.00
5
6
7

$15.00 | $3.00
$18.00 | $4.00
$25.00 | $5.00

Pulling Data from Other Sheets and Books

You can reference cells in other worksheets or workbooks just by clicking on them. Excel makes a notation in the
formula that indicates where to find the cell using the following syntax:

Location How it Appears Example
Same worksheet as the formula Row and Column Cell Reference F7
Same workbook, different worksheet Sheetname! CellReference ‘Sales Total'l F7
Different workbook [WorkbookName] SheetName! CellReference '[Practice Files] Sales Total'! F7

*Single quotes are needed if the name of the worksheet or workbook contains a space

© 2019 Sherry Prindle Dawn Jones Productions  sherryprindle.com  dawn@dawnjones.net 17



Excel Functions

A function is a pre-written formula. There are over 300 functions in Excel, and you can access them in the Formulas
tab or by clicking Fx to the left of the Formula Bar

The most popular functions in Excel are SUM, AVERAGE, MAX, and MIN. You can access these on the Home tab by
clicking the symbol for the Greek letter Sigma Y

To sum, average, find the highest number, or find the lowest number in a range:

1. Click the cell where you want the answer to appear (it doesn’t have to be at the bottom or right of the range)
2. Click the Sum button (or one of the other functions from the drop-down arrow to the right of the Sum button)
3. Highlight the range you want to sum (Excel guesses for you, so make sure the selection is correct)

4. Press Enter

Function Arguments ? >
IF
Logical_test + =
Value_if_true + =
Value_if false T =

Checks whether a condition is met, and returns one value if TRUE, and another value if FALSE.

Logical_test is any value or expression that can be evaluated to TRUE or FALSE.

Formula result =

Help on this function Cancel

Other Functions

Search functions by category in the Formulas tab or use the search box in the Insert Function dialog box, found by
clicking Fx

You can compose a function inside the Insert Function dialog box. This is handy because Excel explains all the
arguments in the formula and also inserts the proper punctuation for you

greater than less than does not equal

greater than or equal to |is blank

© 2019 Sherry Prindle Dawn Jones Productions  sherryprindle.com  dawn@dawnjones.net 18



Calculate Dates

Excel sees dates as numbers of days since January 1, 1900. Excel sees times as fractions of dates. This means you
can easily calculate numbers of days between dates and number of hours or minutes between times

A B C D E
1 Accounts Receivable
2 Current Date: Term:
Invoice Due No. of Days
3  Invoice Date = Amount Date Age Overdue
4 10/18/2012 $577.82
5 1/31/2015 $264.67
6 7/6/2015 $810.21
7 11/5/2012 $577.82
8 12/20/2014 $86.50
9 8/16/2015 $2,595.00
10 9/6/2012 $95.15

The IF Function

The IF function is the function that allows many other functions to work correctly. How many times do you have
everything set, then you realize there is a caveat or exception?

Let’s say | ask the class, “If you have never used Excel before, raise your hand. Those who have used Excel, use the
distance between your finger and thumb to indicate the level of knowledge you feel you have.” That is an IF
function where the Logical Test = Have Never Used Excel before, the Value if True = Raise Your Hand, and the Value
if False = Use the distance between your finger and thumb to indicate your level of knowledge

The IF Function =IF (Logical Test, Value if True, Value if False)

F G H | J K

Annual Perf Mgmt

1 Position Salary Rating Level New Salary Yo
2 Vice President $65,000.00 5 4
3 |Office Manager $88.000.00 2 3
4 General Sales Manager ~ $72.000.00 2 3
5 |Director of Advertising $66,000.00 2 3
& [Marketing Manager $85,000.00 1 4
7 Copy Writer $58,000.00 5 4
8 |Circulation Manager §70.000.00 4 3
s |Accounting Staff $55,000.00 4 2
10 |Division Manager $53 50000 4 4
11 |Division Manager $62,000.00 3 3
1z |Cashier Management $38,000.00 4 1

© 2019 Sherry Prindle Dawn Jones Productions  sherryprindle.com  dawn@dawnjones.net 19




VLOOKUP Function

The VLOOKUP function searches for a value in the leftmost column of a table and returns a value in the same row
from a specified column in the table.

=VLOOKUP (WHAT, WHERE, WHICH)

What = What are you looking up based on?

Where = Where are you looking it up? (Highlight [and name] the table)

Which = Which column number (in your table) do you want to return data from?

An optional fourth argument allows you to input, “FALSE: if an exact match is required.

A B C D E F
i Student \ Score \ Grade \ Score Grade
> Adams 36 0 F
: Baker 68 D 40 D
.« Camden 50 D 70 C
s Dailey 77 C 80 B
-|Gomez 2 A 90 A
7 Hernandez 100 A
s Jackson 74 C
s Maplethorpe 45 D
10 Paulson 60 D
1 Ramirez 89 B
12 Sosa 09 A
13 Thompson 91 A
11 Wilson 59 D
Sparklines

H : . s . . Create Sparklines ? b
Sparklines are word-sized charts you can add into specific cells in this way:

1. Select the data range you want the small chart to be based on

2. In the Insert tab in the Sparklines group, select the Line, Column, or Win/Loss
style

3. In Location Range, indicate the cell where you want the Sparkline to be

To remove a Sparkline, right-click the cell, and in the Sparklines arrow, choose Clear

Choose the data that you want

1%

Data Range:

Choose where you want the sparklines to be placed

1%

Location Range:

Cancel

Insert Comments

1. Select the cell you want to add a comment to

2. In the Review tab or right-click menu, click Insert Comment | "
3. Type the comment G £ e
4. Leave the cell

5. Ared triangle indicates the cell contains a comment
Hover over the cell to view the comment. Right click to edit or delete

$4,567.00 $8‘25?.00.‘ P Shemificte "
the comment 6 $6,443.00 $13,232.00 |
7 $9,899.00 . $20,020.00
g = $5,555.00 $13,999.00
© 2019 Sherry Prindle Dawn Jones Productions  sherryprindle.com  dawn@dawnjones.net 20



5 — Shortcuts, Tips, and Tricks
24 Popular Keyboard Shortcuts

Cut —Ctrl X Insert Row(s) — Alt IR

Copy—CtrI C Insert Column(s) — Alt IC

Paste — Ctrl V AutoSum —Alt =

Undo —Ctrl Z Print Preview — Ctrl F2

Redo —Ctrl Y Select All - Ctrl A
Repeat — Ctrl F4 Show Formulas — Ctrl ~

Freeze panes:

Create Chart—F11

Filter — Ctrl Shift L

Paste Special —Alt HV
Switch Windows — Alt Tab
In-Cell Return — Alt Enter

B,/,U—CtrlB,1,U

1. Click in the cell beneath the row and/or to the right of the column to be frozen

Scroll Sheets — Ctrl
Save — Ctrl S

Open —Ctrl O
Save As—F12
Spell Check — F7

Help — F1

2. On the View tab, in the Window group, click the Freeze Panes drop-down arrow and select Freeze Panes

To unfreeze panes:

1. Click in the cell beneath the row and/or to the right of the column to be frozen

2. On the View tab, in the Window group, click the Freeze Panes drop-down arrow and select Unfreeze Panes

Use Paste Special:

One of Excel's most useful editing tools is Paste Special. This function provides access to a variety of options

regarding how and what is pasted after data is cut or copied

1. Select and copy a range of cells
2. Right-click the destination cell, and choose Paste Special

Caution: Be sure to select an empty area of a worksheet to paste into, or that the appropriate cells will be pasted
over. By default, copied ranges will paste over the same number of cells starting with the selected cell and moving

to the right and down

3. Select Paste Special

4. In the Paste Special dialog box, choose the desired options
5. Click OK

Transpose Data

1. Copy the data to be transposed (without merged title cells)
2. Click the target location

3. Right Click > Paste Special > Transpose

4. Delete the old rows

If the formatting is not right, use Paste Special again and
choose Formatsor. ..

© 2019 Sherry Prindle Dawn Jones Productions  sherryprindle.com
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First Quarter Sales

! January February March Total Sales

| California $9,700.00 $6,887.00 $7,954.00 $24,541.00,

| Florida $5,774.00 $16,912.00 $6,349.00 $29,035.00!

i Georgia $4,712.00 $5,330.00 $1,990.00 $12,032.UU:

| _Indiana__ __$9,057.00 _$3778.00 _ $5555.00 _ $19,200.00|

California Florida Georgia Indiana

$9,700.00 $5,774.00 $4,712.00 $9,957.00
$6,887.00 $16,912.00 $5,330.00 $3,778.00
$7,954.00 $6,349.00 $1,990.00 $5,555.00

LG CIEEY $24,541.00 $29,035.00 $12,032.00 $19,290.00

dawn@dawnjones.net
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Pivot Tables

You can take your spreadsheet apart column by column and put it back together in any configuration you
want. Pivot Tables allow you to analyze and recombine data into reports and charts.

1. Select one cell within the data

2. Click Insert > Pivot Table > OK

3. Check or drag items in the Field List to the Row, Filter, Column, or Values areas

PIVOTTABLE TOOLS
DATA  REVEW  VIEW  DEVELOPER  ANALYZE | DESIGN
pSelection | =] = [# Clear~ [7 Fields, ltems, & Sets n [+]
= (3 e il B |
Insert  Insert Refresh Change Data . PivotChart Recommended | | Field  +/-  Field
p Field Slicer Timeline - Source= | [3 Move PivotTable PivotTables List Buttons Headers
roup Filter Data Adtions Calculations Tools Show -~
D E G H | J -
Sum of Salary Column Labels - PivotTable Fields 57 &3
Row Labels - 1 2] 3 4 5 Grand Total . " .
= Corporate Mgt 55000 46000 133000 106000 340000 FESSRER R RO
Dir. of Advertising o - = 46000 First Name =
Office Manager SRETY En 42000 Last Name
Vice President Auto 197000 Hire Date
Web Designer 58 Starting at: |1 55000 /| Department
= Corporate Staff 194000 Endingat |5 328000 /| Job Title
Accountant 51000 Zy ; 94000 /| Salary
Division Manager : 42000 | Perf Rating
Graphic Designer Cancel 49000 Mgt Level
Marketing Manager 85000 85000 Training Hours -
Technical Writer 58000 58000
= Management Staff 62000 47000 42000 41000 192000 Drag fields between areas below:
Accountant 42000 42000
General Sales Manager 47000 47000 FILTERS COLUMNS
HR Manager 62000 62000 PefRating
Payroll Manager 41000 41000
= Sales 95500 46500 142000
Product Management 95500 46500 142000 fows 2 P
= Section Manager 55000 45000 38500 138500 Department  ~ [ Sumof Salry >
Circulation Manager 38500 38500 Job Title e
Row Labels

Create a Chart

1. Select the data you want to chart

2. Click Insert > Chart

3. Choose the chart type
4. Adjust settings on the Design and Format Ribbons

s vietcon - [ Right click Values column

= Corporate Mgt
Dir. of Advertising
Office Manager
Vice President
Web Designer

-Corporate Staff
Accountant
Division Manager
Graphic Designer
Marketing Manager
Technical Writer

= Management Staff
Accountant
General Sales Manager
HR Manager
Payroll Manager

= Sales
Product Management

= Section Manager
Circulation Manager
Dir. of Shipping

Home Insert  Pagelayout  Formulas  Data  Review  View  Developer O Tell me what you want to do
5 (D Bcasn hr @B MA@ F ) =m = S
‘RE;:;:;ET::G Tae | llusttions |~y B Renug‘:::ded aumn Agal:,- Line Column \(vu":s/ Slicer Tin
Tables Add-ins |_|:|1|:|:l \_B_H mﬂ ‘ours Sparklines Filters
- fe 546 3-D Column
B C o a8 108 44 F
Fourth Qu S
October Novem| 5 ... Total Sales
California | $546.00 | $7.6425 5 55 $40,444.00
lln More Column Charts...
Florida $7,542.00 $653.00 | $8,624.00 $16,819.00
Georgia | $2,356.00 | $6,422.00 | $9,635.00 $18,413.00
Indiana [$12,345.00 | $5,732.00 | $8,532.00 $26,609.00
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Sum of alan
B C

headers to change the

operation

Right click row and column
headers to see Group

options

Explore the Pivot Table
Tools Analyze and Design
ribbons for options such as:

Create Pivot Chart

Hide Field List

Insert Slicer

Adjust Layout

aial [0 | A A G - % s

“
A

Copy
[ Format Cells...
Number Format.

[& Refresh

X Remove "Sum of Salary”

SummarizeValuesBy P | v Sum

Show Values As » Count

[@ ValueField Settings Average
PivotTable Options...

B Hide Field List

B

62000

41000

142000

142000

138500

38500

55000

Max
Min

Product

More Options...
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PivotTable Fields e
Choose fields to add to report: -

First Name =
Last Name
Hire Date
/| Department
] Job Title
| Salary
Perf Rating
Mgt Level
Training Hours -

Drag fields between areas below:

FILTERS COLUMNS

ROWS I VALUES
Department  ~

Job Title -

Sum of Salary =



